Skip to main content

In an upcoming release, GlobalMeet® will no longer support Internet Explorer 9 and 10. To learn more, click here.

Attention iMeet Android App Users! You MUST update to the latest version in the Google Play store in order to join a meeting. Click to learn more.

Meeting Support

How can I ensure my system meets the requirements for GlobalMeet Audio for Skype for Business?

Visit Microsoft Support and search for system requirements to view the minimum system requirements for using GlobalMeet® Audio for Skype for Business (formerly Microsoft® Lync™ Online).

 

  • Was this article helpful?