Skip to main content

As of July, 1, 2017, GlobalMeet® no longer supports Internet Explorer 9 and 10. To learn more, click here.

Attention iMeet Android App Users! You MUST update to the latest version in the Google Play store in order to join a meeting. Click to learn more.

Meeting Support

Why don’t I see the Transfer Meeting option when using GlobalMeet on my mobile device?

You must be a GlobalMeet® account holder and have the required versions of GlobalMeet for Desktop and the GlobalMeet mobile apps installed to see the Transfer Meeting option when using GlobalMeet on your mobile device. The versions required include the following:

  • GlobalMeet for Desktop (version 1.4 or higher)
  • GlobalMeet HD for iPad™ (version 2.0 or higher)
  • GlobalMeet for iPhone™ (version 1.5 or higher)
  • GlobalMeet for Android™ (version 1.2 or higher)