Skip to main content

In an upcoming release, GlobalMeet® will no longer support Internet Explorer 9 and 10. To learn more, click here.

Attention iMeet Android App Users! You MUST update to the latest version in the Google Play store in order to join a meeting. Click to learn more.

Meeting Support

What should I do if I have trouble installing the GlobalMeet toolbar?

Please Contact Us while you are actively trying to install the toolbar, so we can capture any data that is necessary to resolve this issue. 

Note: Make sure your system meets the Minimum System Requirements for GlobalMeet.

 

  • Was this article helpful?